What’s Vulnerable › Vulnerabilities
CVE-2024-4400: Post and Page Builder by BoldGrid – Visual Drag and Drop Editor <= 1.26.4 - Authenticated (Contributer+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plguin for WordPress is vulnerable to Stored Cross-Site Scripting via an unknown parameter in versions up to, and including, 1.26.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- boldgrid Post and Page Builder by BoldGrid – Visual Drag and Drop Editor: before 1.26.5 — fixed in 1.26.5
How to fix
Upgrade to a fixed version: boldgrid Post and Page Builder by BoldGrid – Visual Drag and Drop Editor 1.26.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3087230/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9bb6683a-b8e6-4776-880f-5b48966fc5c6?source=cve
- https://plugins.trac.wordpress.org/changeset/3087230/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9bb6683a-b8e6-4776-880f-5b48966fc5c6?source=cve
Get alerted when CVE-2024-4400 or the next vulnerability affects your stack