What’s Vulnerable › Vulnerabilities

CVE-2024-4404: ElementsKit PRO <= 3.6.1 - Authenticated (Contributor+) Server-Side Request Forgery

Description

The ElementsKit PRO plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 3.6.2 via the 'render_raw' function. This can allow authenticated attackers, with contributor-level permissions and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

Affected products

How to fix

Upgrade to a fixed version: wpmet ElementsKit Pro 3.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4404 or the next vulnerability affects your stack