What’s Vulnerable › Vulnerabilities
CVE-2024-44043: WordPress Photo Gallery by 10Web plugin <= 1.8.27 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in 10Web Photo Gallery by 10Web photo-gallery allows Stored XSS.This issue affects Photo Gallery by 10Web: from n/a through <= 1.8.27.
Affected products
- 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery: before 1.8.28 — fixed in 1.8.28
How to fix
Upgrade to a fixed version: 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery 1.8.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-44043 or the next vulnerability affects your stack