What’s Vulnerable › Vulnerabilities
CVE-2024-44051: WordPress Content Blocks (Custom Post Widget) plugin <= 3.3.5 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Johan van der Wijk Content Blocks (Custom Post Widget) custom-post-widget allows Stored XSS.This issue affects Content Blocks (Custom Post Widget): from n/a through <= 3.3.5.
Affected products
- vanderwijk Content Blocks (Custom Post Widget): before 3.3.6 — fixed in 3.3.6
How to fix
Upgrade to a fixed version: vanderwijk Content Blocks (Custom Post Widget) 3.3.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-44051 or the next vulnerability affects your stack