What’s Vulnerable › Vulnerabilities
CVE-2024-44069
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-19 · updated 2026-06-17
- Weakness: CWE-862
Description
Pi-hole before 6 allows unauthenticated admin/api.php?setTempUnit= calls to change the temperature units of the web dashboard. NOTE: the supplier reportedly does "not consider the bug a security issue" but the specific motivation for letting arbitrary persons change the value (Celsius, Fahrenheit, or Kelvin), seen by the device owner, is unclear.
Affected products
- pi-hole: before 6.0 — fixed in 6.0
How to fix
Upgrade to a fixed version: pi-hole 6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-44069 or the next vulnerability affects your stack