What’s Vulnerable › Vulnerabilities
CVE-2024-44073
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-19 · updated 2026-06-17
- Weakness: CWE-787
Description
The Miniscript (aka rust-miniscript) library before 12.2.0 for Rust allows stack consumption because it does not properly track tree depth.
Affected products
- Rust-Bitcoin Miniscript: before 12.2.0 — fixed in 12.2.0
How to fix
Upgrade to a fixed version: Rust-Bitcoin Miniscript 12.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/rust-bitcoin/rust-miniscript/compare/11.2.0...12.2.0
- https://github.com/rust-bitcoin/rust-miniscript/pull/704
- https://github.com/rust-bitcoin/rust-miniscript/pull/712
Get alerted when CVE-2024-44073 or the next vulnerability affects your stack