What’s Vulnerable › Vulnerabilities
CVE-2024-44085
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
ONLYOFFICE Docs before 8.1.0 allows XSS via a GeneratorFunction Object attack against a macro. This is related to use of an immediately-invoked function expression (IIFE) for a macro. NOTE: this issue exists because of an incorrect fix for CVE-2021-43446 and CVE-2023-50883.
Affected products
- Onlyoffice: before 8.1.0 — fixed in 8.1.0
How to fix
Upgrade to a fixed version: Onlyoffice 8.1.0. Check the vendor advisory for mitigations.
References
- https://www.onlyoffice.com/
- https://www.syss.de/fileadmin/dokumente/Publikationen/Advisories/SYSS-2023-027.txt
- https://www.syss.de/pentest-blog/cross-site-scripting-schwachstelle-in-onlyoffice-docs-syss-2023-027
Get alerted when CVE-2024-44085 or the next vulnerability affects your stack