What’s Vulnerable › Vulnerabilities
CVE-2024-44088: Apache Geode: Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Geode: from 1.1.0 before 1.15.2 — fixed in 1.15.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Geode 1.15.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/161r34nokmcc0w74mnf04lskgb8g1d3g
- http://www.openwall.com/lists/oss-security/2025/10/14/5
Get alerted when CVE-2024-44088 or the next vulnerability affects your stack