What’s Vulnerable › Vulnerabilities
CVE-2024-4419: Fetch JFT <= 1.8.3 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Fetch JFT plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- pjaudiomv Fetch JFT: before 1.8.4 — fixed in 1.8.4
How to fix
Upgrade to a fixed version: pjaudiomv Fetch JFT 1.8.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3089669%40fetch-jft%2Ftrunk&old=3025839%40fetch-jft%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5aca31f5-310f-441b-8d8c-51b7bf2b0b7d?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3089669%40fetch-jft%2Ftrunk&old=3025839%40fetch-jft%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5aca31f5-310f-441b-8d8c-51b7bf2b0b7d?source=cve
Get alerted when CVE-2024-4419 or the next vulnerability affects your stack