What’s Vulnerable › Vulnerabilities
CVE-2024-44308: Apple Multiple Products Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-11-21
- EPSS: 10.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-20 · updated 2026-06-17
Description
The issue was addressed with improved checks. This issue is fixed in Safari 18.1.1, iOS 17.7.2 and iPadOS 17.7.2, iOS 18.1.1 and iPadOS 18.1.1, macOS Sequoia 15.1.1, visionOS 2.1.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited on Intel-based Mac systems.
Affected products
- Apple iPadOS: before 17.7.2; from 18.0 before 18.1.1 — fixed in 17.7.2, 18.1.1
- Apple Iphone Os: before 17.7.2; from 18.0 before 18.1.1 — fixed in 17.7.2, 18.1.1
- Apple macOS: from 15.0 before 15.1.1 — fixed in 15.1.1
- Apple Safari: before 18.1.1 — fixed in 18.1.1
- Apple visionOS: before 2.1.1 — fixed in 2.1.1
- Debian Linux: 11.0
How to fix
Upgrade to a fixed version: Apple iPadOS 17.7.2, 18.1.1; Apple Iphone Os 17.7.2, 18.1.1; Apple macOS 15.1.1; Apple Safari 18.1.1; Apple visionOS 2.1.1. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/121752
- https://support.apple.com/en-us/121753
- https://support.apple.com/en-us/121754
- https://support.apple.com/en-us/121755
- https://support.apple.com/en-us/121756
- http://seclists.org/fulldisclosure/2024/Nov/16
- https://lists.debian.org/debian-lts-announce/2024/12/msg00003.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-44308
Get alerted when CVE-2024-44308 or the next vulnerability affects your stack