What’s Vulnerable › Vulnerabilities
CVE-2024-4442: Salon booking system <= 9.9 - Unauthenticated Arbitrary File Deletion
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-22
Description
The Salon booking system plugin for WordPress is vulnerable to arbitrary file deletion in all versions up to, and including, 9.8. This is due to the plugin not properly validating the path of an uploaded file prior to deleting it. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible. This was partially patched in 9.9, and sufficiently patched in 10.0. CVE-2024-37231 appears to be a duplicate of this issue.
Affected products
- Salon booking system: before 10.0 — fixed in 10.0
How to fix
Upgrade to a fixed version: Salon booking system 10.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/salon-booking-system/tags/9.8/src/SLN/Action/Ajax/RemoveUploadedFile.php#L5
- https://plugins.trac.wordpress.org/changeset/3088196/salon-booking-system#file14
- https://plugins.trac.wordpress.org/changeset/3098413/salon-booking-system/trunk/src/SLN/Action/Ajax/RemoveUploadedFile.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/eaafeadd-f44c-49b1-b900-ef40800c629e?source=cve
- https://plugins.trac.wordpress.org/browser/salon-booking-system/tags/9.8/src/SLN/Action/Ajax/RemoveUploadedFile.php#L5
- https://plugins.trac.wordpress.org/changeset/3088196/salon-booking-system#file14
- https://www.wordfence.com/threat-intel/vulnerabilities/id/eaafeadd-f44c-49b1-b900-ef40800c629e?source=cve
Get alerted when CVE-2024-4442 or the next vulnerability affects your stack