What’s Vulnerable › Vulnerabilities
CVE-2024-4443: Business Directory Plugin – Easy Listing Directories for WordPress <= 6.4.2 - Unauthenticated SQL Injection via listingfields Parameter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-22 · updated 2026-06-17
- Weakness: CWE-89
Description
The Business Directory Plugin – Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘listingfields’ parameter in all versions up to, and including, 6.4.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- strategy11team Business Directory Plugin – Easy Listing Directories for WordPress: before 6.4.3 — fixed in 6.4.3
How to fix
Upgrade to a fixed version: strategy11team Business Directory Plugin – Easy Listing Directories for WordPress 6.4.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/business-directory-plugin/trunk/includes/fields/class-fieldtypes-select.php#L110
- https://plugins.trac.wordpress.org/changeset/3089626/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/982fb304-08d6-4195-97a3-f18e94295492?source=cve
- https://plugins.trac.wordpress.org/browser/business-directory-plugin/trunk/includes/fields/class-fieldtypes-select.php#L110
- https://plugins.trac.wordpress.org/changeset/3089626/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/982fb304-08d6-4195-97a3-f18e94295492?source=cve
Get alerted when CVE-2024-4443 or the next vulnerability affects your stack