What’s Vulnerable › Vulnerabilities
CVE-2024-4445: WP Compress – Image Optimizer [All-In-One] <= 6.20.01 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP Compress – Image Optimizer [All-In-One] plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the several functions in versions up to, and including, 6.20.01. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to edit plugin settings, including storing cross-site scripting, in multisite environments.
Affected products
- aresit WP Compress – Instant Performance & Speed Optimization: before 6.20.02 — fixed in 6.20.02
How to fix
Upgrade to a fixed version: aresit WP Compress – Instant Performance & Speed Optimization 6.20.02. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/trunk/classes/mu.class.php?rev=2946135
- https://plugins.trac.wordpress.org/changeset/3082085/#file655
- https://www.wordfence.com/threat-intel/vulnerabilities/id/830f53a4-da3b-4a95-99f1-c4a4c8e6944c?source=cve
- https://plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/trunk/classes/mu.class.php?rev=2946135
- https://plugins.trac.wordpress.org/changeset/3082085/#file655
- https://www.wordfence.com/threat-intel/vulnerabilities/id/830f53a4-da3b-4a95-99f1-c4a4c8e6944c?source=cve
Get alerted when CVE-2024-4445 or the next vulnerability affects your stack