What’s Vulnerable › Vulnerabilities
CVE-2024-4450: AliExpress Dropshipping with AliNext Lite <= 3.3.6 - Missing Authorization via Several Functions
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
- Weakness: CWE-862
Description
The AliExpress Dropshipping with AliNext Lite plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several functions in the ImportAjaxController.php file in all versions up to, and including, 3.3.6. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform several actions like importing and modifying products. CVE-2024-37210 is likely a duplicate of this issue.
Affected products
- ali2woo AliExpress Dropshipping Plugin for WooCommerce & WordPress: before 3.3.7 — fixed in 3.3.7
How to fix
Upgrade to a fixed version: ali2woo AliExpress Dropshipping Plugin for WooCommerce & WordPress 3.3.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ali2woo-lite/trunk/includes/classes/controller/ImportAjaxController.php
- https://plugins.trac.wordpress.org/changeset/3111831#file10
- https://www.wordfence.com/threat-intel/vulnerabilities/id/01836c2c-0976-493e-8b13-1c7c702d1d2c?source=cve
- https://plugins.trac.wordpress.org/browser/ali2woo-lite/trunk/includes/classes/controller/ImportAjaxController.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/01836c2c-0976-493e-8b13-1c7c702d1d2c?source=cve
Get alerted when CVE-2024-4450 or the next vulnerability affects your stack