What’s Vulnerable › Vulnerabilities
CVE-2024-4452: ElementsKit Pro <= 3.6.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The ElementsKit Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ parameter in versions up to, and including, 3.6.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpmet ElementsKit Pro: before 3.6.2 — fixed in 3.6.2
How to fix
Upgrade to a fixed version: wpmet ElementsKit Pro 3.6.2. Check the vendor advisory for mitigations.
References
- https://wpmet.com/plugin/elementskit/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/488ac848-786e-4100-a387-5a40e8fc4175?source=cve
- https://wpmet.com/plugin/elementskit/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/488ac848-786e-4100-a387-5a40e8fc4175?source=cve
Get alerted when CVE-2024-4452 or the next vulnerability affects your stack