What’s Vulnerable › Vulnerabilities
CVE-2024-4455: YITH WooCommerce Ajax Search <= 2.4.0 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The YITH WooCommerce Ajax Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘item’ parameter in versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- YITHEMES YITH WooCommerce Ajax Search: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: YITHEMES YITH WooCommerce Ajax Search 2.4.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/yith-woocommerce-ajax-search/trunk/includes/admin/class-yith-wcas-admin-statistic-list-table.php#L213
- https://plugins.trac.wordpress.org/changeset/3091321
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cf0f5fd4-cd06-4d11-9f22-1f417b546afb?source=cve
- https://plugins.trac.wordpress.org/browser/yith-woocommerce-ajax-search/trunk/includes/admin/class-yith-wcas-admin-statistic-list-table.php#L213
- https://plugins.trac.wordpress.org/changeset/3091321
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cf0f5fd4-cd06-4d11-9f22-1f417b546afb?source=cve
Get alerted when CVE-2024-4455 or the next vulnerability affects your stack