What’s Vulnerable › Vulnerabilities
CVE-2024-4456
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
In affected versions of Octopus Server with certain access levels it was possible to embed a Cross-Site Scripting payload on the audit page.
Affected products
- Octopus Deploy Octopus Server: from 3.0.0 before 2023.4.8338; from 2024.1.437 before 2024.1.11127 — fixed in 2023.4.8338, 2024.1.11127
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2023.4.8338, 2024.1.11127. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2024/sa2024-04/
- https://advisories.octopus.com/post/2024/sa2024-04/
Get alerted when CVE-2024-4456 or the next vulnerability affects your stack