What’s Vulnerable › Vulnerabilities
CVE-2024-4458: Themesflat Addons For Elementor <= 2.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via URLs
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Themesflat Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting in several widgets via URL parameters in all versions up to, and including, 2.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Themesflat Addons For Elementor: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: Themesflat Addons For Elementor 2.1.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3099056%40themesflat-addons-for-elementor&old=3097003%40themesflat-addons-for-elementor&sfp_email=&sfph_mail=#file25
- https://wordpress.org/plugins/themesflat-addons-for-elementor/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f0ff03ab-eeb9-4445-92c8-326783d4b10e?source=cve
- https://wordpress.org/plugins/themesflat-addons-for-elementor/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f0ff03ab-eeb9-4445-92c8-326783d4b10e?source=cve
Get alerted when CVE-2024-4458 or the next vulnerability affects your stack