What’s Vulnerable › Vulnerabilities
CVE-2024-4473: Sydney Toolbox <= 1.31 - Authenticated (Contributor+) Stored Cross-Site Scripting via aThemes: Portfolio Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Sydney Toolbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the "aThemes: Portfolio" widget in all versions up to, and including, 1.31 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- smub Sydney Toolbox: before 1.32 — fixed in 1.32
How to fix
Upgrade to a fixed version: smub Sydney Toolbox 1.32. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3082233/sydney-toolbox
- https://www.wordfence.com/threat-intel/vulnerabilities/id/60f16abd-951b-48a0-a363-0221f7e0957d?source=cve
- https://plugins.trac.wordpress.org/changeset/3082233/sydney-toolbox
- https://www.wordfence.com/threat-intel/vulnerabilities/id/60f16abd-951b-48a0-a363-0221f7e0957d?source=cve
Get alerted when CVE-2024-4473 or the next vulnerability affects your stack