What’s Vulnerable › Vulnerabilities
CVE-2024-4483: Email Encoder < 2.2.2 - Admin+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Email Encoder WordPress plugin before 2.2.2 does not escape the WP_Email_Encoder_Bundle_options[protection_text] parameter before outputting it back in an attribute in an admin page, leading to a Stored Cross-Site Scripting
Affected products
- Email Encoder: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: Email Encoder 2.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8f2ac76c-f3f8-41f9-a32a-f414825cf6f1/
- https://wpscan.com/vulnerability/8f2ac76c-f3f8-41f9-a32a-f414825cf6f1/
Get alerted when CVE-2024-4483 or the next vulnerability affects your stack