What’s Vulnerable › Vulnerabilities
CVE-2024-4487: Blocksy Companion <= 2.0.45 - Authenticated (Contributor+) Stored Cross-Site Scripting via SVG Uploads
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Blocksy Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG uploads in versions up to, and including, 2.0.45 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- creativethemeshq Blocksy Companion: before 2.0.46 — fixed in 2.0.46
How to fix
Upgrade to a fixed version: creativethemeshq Blocksy Companion 2.0.46. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/blocksy-companion/tags/2.0.45/framework/features/svg.php#L20
- https://plugins.trac.wordpress.org/changeset/3084198/#file18
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5208529c-4ac3-42a4-82d0-7f4d2e486236?source=cve
- https://plugins.trac.wordpress.org/browser/blocksy-companion/tags/2.0.45/framework/features/svg.php#L20
- https://plugins.trac.wordpress.org/changeset/3084198/#file18
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5208529c-4ac3-42a4-82d0-7f4d2e486236?source=cve
Get alerted when CVE-2024-4487 or the next vulnerability affects your stack