What’s Vulnerable › Vulnerabilities
CVE-2024-4488: Royal Elementor Addons and Templates <= 1.3.976 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Royal Elementor Addons and Templates for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘inline_list’ parameter in versions up to, and including, 1.3.976 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.3.977 — fixed in 1.3.977
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.977. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/royal-elementor-addons/trunk/modules/form-builder/widgets/wpr-form-builder.php#L3238
- https://plugins.trac.wordpress.org/changeset/3097775/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cb0ac434-7e85-44d4-b21e-df462f63cd9c?source=cve
- https://plugins.trac.wordpress.org/browser/royal-elementor-addons/trunk/modules/form-builder/widgets/wpr-form-builder.php#L3238
- https://plugins.trac.wordpress.org/changeset/3097775/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cb0ac434-7e85-44d4-b21e-df462f63cd9c?source=cve
Get alerted when CVE-2024-4488 or the next vulnerability affects your stack