What’s Vulnerable › Vulnerabilities
CVE-2024-44931: gpio: prevent potential speculation leaks in gpio_device_get_desc()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-26 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: prevent potential speculation leaks in gpio_device_get_desc() Userspace may trigger a speculative read of an address outside the gpio descriptor array. Users can do that by calling gpio_ioctl() with an offset out of range. Offset is copied from user and then used as an array index to get the gpio descriptor without sanitization in gpio_device_get_desc(). This change ensures that the offset is sanitized by using array_index_nospec() to mitigate any possibility of speculative information leaks. This bug was discovered and resolved using Coverity Static Analysis Security Testing (SAST) by Synopsys, Inc.
Affected products
- Linux kernel: before 6.6.46; from 6.7 before 6.10.5 — fixed in 6.10.5, 6.6.46
How to fix
Upgrade to a fixed version: Linux kernel 6.10.5, 6.6.46. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/18504710442671b02d00e6db9804a0ad26c5a479
- https://git.kernel.org/stable/c/1b955f786a4bcde8c0ccb2b7d519def2acb6f3cc
- https://git.kernel.org/stable/c/672c19165fc96dfad531a5458e0b3cdab414aae4
- https://git.kernel.org/stable/c/9ae2d8e75b741dbcb0da374753f972410e83b5f3
- https://git.kernel.org/stable/c/9d682e89c44bd5819b01f3fbb45a8e3681a4b6d0
- https://git.kernel.org/stable/c/c65ab97efcd438cb4e9f299400f2ea55251f3a67
- https://git.kernel.org/stable/c/d776c0486b03a5c4afca65b8ff44573592bf93bb
- https://git.kernel.org/stable/c/d795848ecce24a75dfd46481aee066ae6fe39775
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-44931 or the next vulnerability affects your stack