What’s Vulnerable › Vulnerabilities
CVE-2024-44954: ALSA: line6: Fix racy access to midibuf
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-08-04
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: line6: Fix racy access to midibuf There can be concurrent accesses to line6 midibuf from both the URB completion callback and the rawmidi API access. This could be a cause of KMSAN warning triggered by syzkaller below (so put as reported-by here). This patch protects the midibuf call of the former code path with a spinlock for avoiding the possible races.
Affected products
- Linux kernel: before 4.19.320; from 4.20 (excl.) before 5.4.282; from 5.5 before 5.10.224; from 5.11 (excl.) before 5.15.165; from 5.16 before 6.1.105; from 6.2 before 6.6.46 — fixed in 4.19.320, 5.10.224, 5.15.165, 5.4.282, 6.1.105, 6.10.5
How to fix
Upgrade to a fixed version: Linux kernel 4.19.320, 5.10.224, 5.15.165, 5.4.282. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/15b7a03205b31bc5623378c190d22b7ff60026f1
- https://git.kernel.org/stable/c/40f3d5cb0e0cbf7fa697913a27d5d361373bdcf5
- https://git.kernel.org/stable/c/51d87f11dd199bbc6a85982b088ff27bde53b48a
- https://git.kernel.org/stable/c/535df7f896a568a8a1564114eaea49d002cb1747
- https://git.kernel.org/stable/c/643293b68fbb6c03f5e907736498da17d43f0d81
- https://git.kernel.org/stable/c/a54da4b787dcac60b598da69c9c0072812b8282d
- https://git.kernel.org/stable/c/c80f454a805443c274394b1db0d1ebf477abd94e
- https://git.kernel.org/stable/c/e7e7d2b180d8f297cea6db43ea72402fd33e1a29
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-44954 or the next vulnerability affects your stack