What’s Vulnerable › Vulnerabilities
CVE-2024-44977: drm/amdgpu: Validate TA binary size
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu: Validate TA binary size Add TA binary size validation to avoid OOB write. (cherry picked from commit c0a04e3570d72aaf090962156ad085e37c62e442)
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.19 before 6.1.107; from 6.2 (excl.) before 6.6.48; from 6.7 (excl.) before 6.10.7; 6.11-rc1, 6.11-rc2, 6.11-rc3, 6.11-rc4 — fixed in 6.1.107, 6.10.7, 6.6.48
How to fix
Upgrade to a fixed version: Linux kernel 6.1.107, 6.10.7, 6.6.48. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/50553ea7cbd3344fbf40afb065f6a2d38171c1ad
- https://git.kernel.org/stable/c/5ab8793b9a6cc059f503cbe6fe596f80765e0f19
- https://git.kernel.org/stable/c/c99769bceab4ecb6a067b9af11f9db281eea3e2a
- https://git.kernel.org/stable/c/e562415248f402203e7fb6d8c38c1b32fa99220f
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-44977 or the next vulnerability affects your stack