What’s Vulnerable › Vulnerabilities
CVE-2024-44985: ipv6: prevent possible UAF in ip6_xmit()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ipv6: prevent possible UAF in ip6_xmit() If skb_expand_head() returns NULL, skb has been freed and the associated dst/idev could also have been freed. We must use rcu_read_lock() to prevent a possible UAF.
Affected products
- Linux kernel: from 5.15 before 5.15.166; from 5.16 before 6.1.107; from 6.2 before 6.6.48; from 6.7 before 6.10.7; 6.11-rc1, 6.11-rc2, 6.11-rc3, 6.11-rc4 — fixed in 5.15.166, 6.1.107, 6.10.7, 6.6.48
How to fix
Upgrade to a fixed version: Linux kernel 5.15.166, 6.1.107, 6.10.7, 6.6.48. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/124b428fe28064c809e4237b0b38e97200a8a4a8
- https://git.kernel.org/stable/c/2d5ff7e339d04622d8282661df36151906d0e1c7
- https://git.kernel.org/stable/c/38a21c026ed2cc7232414cb166efc1923f34af17
- https://git.kernel.org/stable/c/975f764e96f71616b530e300c1bb2ac0ce0c2596
- https://git.kernel.org/stable/c/b3a3d5333c13a1be57499581eab4a8fc94d57f36
- https://git.kernel.org/stable/c/c47e022011719fc5727bca661d662303180535ba
- https://git.kernel.org/stable/c/fc88d6c1f2895a5775795d82ec581afdff7661d1
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-44985 or the next vulnerability affects your stack