What’s Vulnerable › Vulnerabilities
CVE-2024-44988: net: dsa: mv88e6xxx: Fix out-of-bound access
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: net: dsa: mv88e6xxx: Fix out-of-bound access If an ATU violation was caused by a CPU Load operation, the SPID could be larger than DSA_MAX_PORTS (the size of mv88e6xxx_chip.ports[] array).
Affected products
- Linux kernel: from 4.19.21 before 4.20; from 4.20.8 before 5.0; from 5.0 before 5.4.283; from 5.5 before 5.10.225; from 5.11 before 5.15.166; from 5.16 before 6.1.107 — fixed in 4.20, 5.0, 5.10.225, 5.15.166, 5.4.283, 6.1.107
How to fix
Upgrade to a fixed version: Linux kernel 4.20, 5.0, 5.10.225, 5.15.166. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/050e7274ab2150cd212b2372595720e7b83a15bd
- https://git.kernel.org/stable/c/18b2e833daf049223ab3c2efdf8cdee08854c484
- https://git.kernel.org/stable/c/4a88fca95c8df3746b71e31f44a02d35f06f9864
- https://git.kernel.org/stable/c/528876d867a23b5198022baf2e388052ca67c952
- https://git.kernel.org/stable/c/a10d0337115a6d223a1563d853d4455f05d0b2e3
- https://git.kernel.org/stable/c/d39f5be62f098fe367d672b4dd4bc4b2b80e08e7
- https://git.kernel.org/stable/c/f7d8c2fabd39250cf2333fbf8eef67e837f90a5d
- https://git.kernel.org/stable/c/f87ce03c652dba199aef15ac18ade3991db5477e
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-44988 or the next vulnerability affects your stack