What’s Vulnerable › Vulnerabilities
CVE-2024-44998: atm: idt77252: prevent use after free in dequeue_rx()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: atm: idt77252: prevent use after free in dequeue_rx() We can't dereference "skb" after calling vcc->push() because the skb is released.
Affected products
- Linux kernel: from 2.6.12 before 4.19.321; from 4.20 before 5.4.283; from 5.5 before 5.10.225; from 5.11 before 5.15.166; from 5.16 before 6.1.107; from 6.2 before 6.6.48 — fixed in 4.19.321, 5.10.225, 5.15.166, 5.4.283, 6.1.107, 6.10.7
How to fix
Upgrade to a fixed version: Linux kernel 4.19.321, 5.10.225, 5.15.166, 5.4.283. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/09e086a5f72ea27c758b3f3b419a69000c32adc1
- https://git.kernel.org/stable/c/1cece837e387c039225f19028df255df87a97c0d
- https://git.kernel.org/stable/c/24cf390a5426aac9255205e9533cdd7b4235d518
- https://git.kernel.org/stable/c/379a6a326514a3e2f71b674091dfb0e0e7522b55
- https://git.kernel.org/stable/c/628ea82190a678a56d2ec38cda3addf3b3a6248d
- https://git.kernel.org/stable/c/91b4850e7165a4b7180ef1e227733bcb41ccdf10
- https://git.kernel.org/stable/c/a9a18e8f770c9b0703dab93580d0b02e199a4c79
- https://git.kernel.org/stable/c/ef23c18ab88e33ce000d06a5c6aad0620f219bfd
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-44998 or the next vulnerability affects your stack