What’s Vulnerable › Vulnerabilities
CVE-2024-45007: char: xillybus: Don't destroy workqueue from work item running on it
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: char: xillybus: Don't destroy workqueue from work item running on it Triggered by a kref decrement, destroy_workqueue() may be called from within a work item for destroying its own workqueue. This illegal situation is averted by adding a module-global workqueue for exclusive use of the offending work item. Other work items continue to be queued on per-device workqueues to ensure performance.
Affected products
- Linux kernel: from 5.14 before 5.15.166; from 5.16 before 6.1.107; from 6.2 before 6.6.48; from 6.7 before 6.10.7; 6.11-rc1, 6.11-rc2, 6.11-rc3 — fixed in 5.15.166, 6.1.107, 6.10.7, 6.6.48
How to fix
Upgrade to a fixed version: Linux kernel 5.15.166, 6.1.107, 6.10.7, 6.6.48. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/409b495f8e3300d5fba08bc817fa8825dae48cc9
- https://git.kernel.org/stable/c/5d3567caff2a1d678aa40cc74a54e1318941fad3
- https://git.kernel.org/stable/c/a7ad105b12256ec7fb6d6d1a0e2e60f00b7da157
- https://git.kernel.org/stable/c/aa1a19724fa2c31e97a9be48baedd4692b265157
- https://git.kernel.org/stable/c/ccbde4b128ef9c73d14d0d7817d68ef795f6d131
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-45007 or the next vulnerability affects your stack