What’s Vulnerable › Vulnerabilities
CVE-2024-45010: mptcp: pm: only mark 'subflow' endp as available
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: mptcp: pm: only mark 'subflow' endp as available Adding the following warning ... WARN_ON_ONCE(msk->pm.local_addr_used == 0) ... before decrementing the local_addr_used counter helped to find a bug when running the "remove single address" subtest from the mptcp_join.sh selftests. Removing a 'signal' endpoint will trigger the removal of all subflows linked to this endpoint via mptcp_pm_nl_rm_addr_or_subflow() with rm_type == MPTCP_MIB_RMSUBFLOW. This will decrement the local_addr_used counter, which is wrong in this case because this counter is linked to 'subflow' endpoints, and here it is a 'signal' endpoint that is being removed. Now, the counter is decremented, only if the ID is being used outside of mptcp_pm_nl_rm_addr_or_subflow(), only for 'subflow' endpoints, and if the ID is not 0 -- local_addr_used is not taking into account these ones. This marking of the ID as being available, and the decrement is done no matter if a subflow using this ID is currently available, because the subflow could have been closed before.
Affected products
- Linux kernel: from 5.13 before 6.1.108; from 6.2 before 6.6.48; from 6.7 before 6.10.7; 6.11-rc1, 6.11-rc2, 6.11-rc3, 6.11-rc4 — fixed in 6.1.108, 6.10.7, 6.6.48
How to fix
Upgrade to a fixed version: Linux kernel 6.1.108, 6.10.7, 6.6.48. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/322ea3778965da72862cca2a0c50253aacf65fe6
- https://git.kernel.org/stable/c/43cf912b0b0fc7b4fd12cbc735d1f5afb8e1322d
- https://git.kernel.org/stable/c/7fdc870d08960961408a44c569f20f50940e7d4f
- https://git.kernel.org/stable/c/9849cfc67383ceb167155186f8f8fe8a896b60b3
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-45010 or the next vulnerability affects your stack