What’s Vulnerable › Vulnerabilities
CVE-2024-45021: memcg_write_event_control(): fix a user-triggerable oops
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-08-04
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: memcg_write_event_control(): fix a user-triggerable oops we are *not* guaranteed that anything past the terminating NUL is mapped (let alone initialized with anything sane).
Affected products
- Linux kernel: from 2.6.34 before 4.19.321; from 4.20 before 5.4.283; from 5.5 before 5.10.225; from 5.11 before 5.15.166; from 5.16 before 6.1.107; from 6.2 before 6.6.48 — fixed in 4.19.321, 5.10.225, 5.15.166, 5.4.283, 6.1.107, 6.10.7
How to fix
Upgrade to a fixed version: Linux kernel 4.19.321, 5.10.225, 5.15.166, 5.4.283. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/046667c4d3196938e992fba0dfcde570aa85cd0e
- https://git.kernel.org/stable/c/0fbe2a72e853a1052abe9bc2b7df8ddb102da227
- https://git.kernel.org/stable/c/1b37ec85ad95b612307627758c6018cd9d92cca8
- https://git.kernel.org/stable/c/21b578f1d599edb87462f11113c5b0fc7a04ac61
- https://git.kernel.org/stable/c/43768fa80fd192558737e24ed6548f74554611d7
- https://git.kernel.org/stable/c/ad149f5585345e383baa65f1539d816cd715fd3b
- https://git.kernel.org/stable/c/f1aa7c509aa766080db7ab3aec2e31b1df09e57c
- https://git.kernel.org/stable/c/fa5bfdf6cb5846a00e712d630a43e3cf55ccb411
- https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-45021 or the next vulnerability affects your stack