What’s Vulnerable › Vulnerabilities
CVE-2024-45031: Apache Syncope: Stored XSS in Console and Enduser
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
When editing objects in the Syncope Console, incomplete HTML tags could be used to bypass HTML sanitization. This made it possible to inject stored XSS payloads which would trigger for other users during ordinary usage of the application. XSS payloads could also be injected in Syncope Enduser when editing “Personal Information” or “User Requests”: such payloads would trigger for administrators in Syncope Console, thus enabling session hijacking. Users are recommended to upgrade to version 3.0.9, which fixes this issue.
Affected products
- Apache Software Foundation Apache Syncope: from 2.1.0 before 3.0.9 — fixed in 3.0.9
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 3.0.9. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/fn567pfmo3s55ofkc42drz8b4kgbhp9m
- http://www.openwall.com/lists/oss-security/2024/10/24/2
Get alerted when CVE-2024-45031 or the next vulnerability affects your stack