What’s Vulnerable › Vulnerabilities
CVE-2024-45033: Apache Airflow Fab Provider: Application does not invalidate session after password change via Airflow cli
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider. This issue affects Apache Airflow Fab Provider: before 1.5.2. When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9 which was addressed in Apache-Airflow 2.7.0 Users are recommended to upgrade to version 1.5.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Airflow FAB provider: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow FAB provider 1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/45139
- https://lists.apache.org/thread/yw535346rk766ybzpqtvrl36sjj789st
Get alerted when CVE-2024-45033 or the next vulnerability affects your stack