What’s Vulnerable › Vulnerabilities
CVE-2024-45034: Apache Airflow: Authenticated DAG authors could execute code on scheduler nodes
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-07 · updated 2026-06-17
- Weakness: CWE-250
Description
Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler, where the scheduler is not supposed to execute code submitted by the DAG author. Users are advised to upgrade to version 2.10.1 or later, which has fixed the vulnerability.
Affected products
- Apache Airflow: before 2.10.1 — fixed in 2.10.1
How to fix
Upgrade to a fixed version: Apache Airflow 2.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/41672
- https://lists.apache.org/thread/b4fcw33vh60yfg9990n5vmc7sy2dcgjx
- http://www.openwall.com/lists/oss-security/2024/09/06/3
Get alerted when CVE-2024-45034 or the next vulnerability affects your stack