What’s Vulnerable › Vulnerabilities
CVE-2024-45048: XML External Entity Reference (XXE) in PHPSpreadsheet
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-28 · updated 2026-06-17
- Weakness: CWE-611
Description
PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Affected versions are subject to a bypassing of a filter which allows for an XXE-attack. This in turn allows attacker to obtain contents of local files, even if error reporting is muted. This vulnerability has been addressed in release version 2.2.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- PHPOffice PhpSpreadsheet: before 1.29.1; from 2.0.0 before 2.2.1 — fixed in 1.29.1, 2.2.1
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.1, 2.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/commit/bea2d4b30f24bcc8a7712e208d1359e603b45dda
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-ghg6-32f9-2jp7
Get alerted when CVE-2024-45048 or the next vulnerability affects your stack