What’s Vulnerable › Vulnerabilities
CVE-2024-45051: Bypass of email address validation via encoded email addresses in Discourse
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-287
Description
Discourse is an open source platform for community discussion. A maliciously crafted email address could allow an attacker to bypass domain-based restrictions and gain access to private sites, categories and/or groups. This issue has been patched in the latest stable, beta and tests-passed version of Discourse. All users area are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.3.2; before 3.4.0; 3.4.0-beta1 — fixed in 3.3.2, 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.3.2, 3.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45051 or the next vulnerability affects your stack