What’s Vulnerable › Vulnerabilities
CVE-2024-45053: Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-04 · updated 2026-06-17
- Weakness: CWE-1336
Description
Fides is an open-source privacy engineering platform. Starting in version 2.19.0 and prior to version 2.44.0, the Email Templating feature uses Jinja2 without proper input sanitization or rendering environment restrictions, allowing for Server-Side Template Injection that grants Remote Code Execution to privileged users. A privileged user refers to an Admin UI user with the default `Owner` or `Contributor` role, who can escalate their access and execute code on the underlying Fides Webserver container where the Jinja template rendering function is executed. The vulnerability has been patched in Fides version `2.44.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no workarounds.
Affected products
- ethyca fides: from 2.19.0 before 2.44.0 — fixed in 2.44.0
How to fix
Upgrade to a fixed version: ethyca fides 2.44.0. Check the vendor advisory for mitigations.
References
- https://github.com/ethyca/fides/commit/829cbd9cb5ef9c814fbac1ed6800e8d939d359c5
- https://github.com/ethyca/fides/security/advisories/GHSA-c34r-238x-f7qx
Get alerted when CVE-2024-45053 or the next vulnerability affects your stack