What’s Vulnerable › Vulnerabilities
CVE-2024-45054: Potential Permission Leakage of Cluster Level in hwameistor
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-28 · updated 2026-06-17
- Weakness: CWE-200
Description
Hwameistor is an HA local storage system for cloud-native stateful workloads. This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation. This issue has been patched in version 0.14.6. All users are advised to upgrade. Users unable to upgrade should update and limit the ClusterRole using security-role.
Affected products
- hwameistor: before 0.14.6 — fixed in 0.14.6
How to fix
Upgrade to a fixed version: hwameistor 0.14.6. Check the vendor advisory for mitigations.
References
- https://github.com/hwameistor/hwameistor/blob/main/helm/hwameistor/templates/clusterrole.yaml
- https://github.com/hwameistor/hwameistor/commit/edf4cebed73cadd230bf97eab65c5311f2858450
- https://github.com/hwameistor/hwameistor/issues/1457
- https://github.com/hwameistor/hwameistor/issues/1460
- https://github.com/hwameistor/hwameistor/security/advisories/GHSA-mgwr-h7mv-fh29
Get alerted when CVE-2024-45054 or the next vulnerability affects your stack