What’s Vulnerable › Vulnerabilities
CVE-2024-45060: Unauthenticated Cross-Site-Scripting (XSS) in sample file in PHPSpreadsheet
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-79
Description
PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. One of the sample scripts in PhpSpreadsheet is susceptible to a cross-site scripting (XSS) vulnerability due to improper handling of input where a number is expected leading to formula injection. The code in in `45_Quadratic_equation_solver.php` concatenates the user supplied parameters directly into spreadsheet formulas. This allows an attacker to take control over the formula and output unsanitized data into the page, resulting in JavaScript execution. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- PHPOffice PhpSpreadsheet: before 1.29.2; from 2.0.0 before 2.1.1; from 2.2.0 before 2.3.0 — fixed in 1.29.2, 2.1.1, 2.3.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.2, 2.1.1, 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/blob/d50b8b5de7e30439fb57eae7df9ea90e79fa0f2d/samples/Basic/45_Quadratic_equation_solver.php#L56
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-v66g-p9x6-v98p
Get alerted when CVE-2024-45060 or the next vulnerability affects your stack