What’s Vulnerable › Vulnerabilities

CVE-2024-45145: Lightroom Desktop | Out-of-bounds Read (CWE-125)

Description

Lightroom Desktop versions 7.4.1, 13.5, 12.5.1 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Lightroom Classic 12.5.1, 13.5.1, 7.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45145 or the next vulnerability affects your stack