What’s Vulnerable › Vulnerabilities
CVE-2024-45160
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-09 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect credential validation in LemonLDAP::NG 2.18.x and 2.19.x before 2.19.2 allows attackers to bypass OAuth2 client authentication via an empty client_password parameter (client secret).
Affected products
- Lemonldap-Ng: from 2.18.0 before 2.19.2 — fixed in 2.19.2
How to fix
Upgrade to a fixed version: Lemonldap-Ng 2.19.2. Check the vendor advisory for mitigations.
References
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/commit/06d771cbc2d5c752354c50f83e4912e5879f9aa2
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/commit/236cdfe42c1dc04a15a4a40c5e6a8c2e858d71d7
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/commit/696f49a0855faeb271096dccb8381e2129687c3d
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/3223
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/tags
Get alerted when CVE-2024-45160 or the next vulnerability affects your stack