What’s Vulnerable › Vulnerabilities
CVE-2024-45201
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-22 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in llama_index before 0.10.38. download/integration.py includes an exec call for import {cls_name}.
Affected products
- run-llama/llama_index: before 0.10.38 — fixed in 0.10.38
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.10.38. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/compare/v0.10.37...v0.10.38
- https://github.com/run-llama/llama_index/pull/13523
Get alerted when CVE-2024-45201 or the next vulnerability affects your stack