What’s Vulnerable › Vulnerabilities

CVE-2024-45216: Apache Solr: Authentication bypass possible using a fake URL Path ending

Description

Improper Authentication vulnerability in Apache Solr. Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Solr 8.11.4, 9.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-45216 or the next vulnerability affects your stack