What’s Vulnerable › Vulnerabilities
CVE-2024-45230
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 25.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-08 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in Django 5.1 before 5.1.1, 5.0 before 5.0.9, and 4.2 before 4.2.16. The urlize() and urlizetrunc() template filters are subject to a potential denial-of-service attack via very large inputs with a specific sequence of characters.
Affected products
- Django: from 4.2.0 before 4.2.16; from 5.0 before 5.0.9; 5.1 — fixed in 4.2.16, 5.0.9
How to fix
Upgrade to a fixed version: Django 4.2.16, 5.0.9. Check the vendor advisory for mitigations.
References
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/sep/03/security-releases/
Get alerted when CVE-2024-45230 or the next vulnerability affects your stack