What’s Vulnerable › Vulnerabilities
CVE-2024-45287: Multiple vulnerabilities in libnv
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-05 · updated 2026-06-17
- Weakness: CWE-131
Description
A malicious value of size in a structure of packed libnv can cause an integer overflow, leading to the allocation of a smaller buffer than required for the parsed data.
Affected products
- FreeBSD: from 13.0 before 13.3; 13.3, 13.3-p1, 13.3-p2, 13.3-p3, 13.3-p4, 13.3-p5 (+18) — fixed in 13.3
How to fix
Upgrade to a fixed version: FreeBSD 13.3. Check the vendor advisory for mitigations.
References
- https://security.freebsd.org/advisories/FreeBSD-SA-24:09.libnv.asc
- https://security.netapp.com/advisory/ntap-20240926-0010/
Get alerted when CVE-2024-45287 or the next vulnerability affects your stack