What’s Vulnerable › Vulnerabilities
CVE-2024-45290: Path traversal and Server-Side Request Forgery when opening XLSX files in PHPSpreadsheet
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-36
Description
PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. It's possible for an attacker to construct an XLSX file which links media from external URLs. When opening the XLSX file, PhpSpreadsheet retrieves the image size and type by reading the file contents, if the provided path is a URL. By using specially crafted `php://filter` URLs an attacker can leak the contents of any file or URL. Note that this vulnerability is different from GHSA-w9xv-qf98-ccq4, and resides in a different component. An attacker can access any file on the server, or leak information form arbitrary URLs, potentially exposing sensitive information such as AWS IAM credentials. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- PHPOffice PhpSpreadsheet: before 1.29.2; from 2.0.0 before 2.1.1; from 2.2.0 before 2.3.0 — fixed in 1.29.2, 2.1.1, 2.3.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.2, 2.1.1, 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-5gpr-w2p5-6m37
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-w9xv-qf98-ccq4
Get alerted when CVE-2024-45290 or the next vulnerability affects your stack