What’s Vulnerable › Vulnerabilities
CVE-2024-45292: PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via JavaScript hyperlinks
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-79
Description
PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. `\PhpOffice\PhpSpreadsheet\Writer\Html` does not sanitize "javascript:" URLs from hyperlink `href` attributes, resulting in a Cross-Site Scripting vulnerability. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- PHPOffice PhpSpreadsheet: before 1.29.2; from 2.0.0 before 2.1.1; from 2.2.0 before 2.3.0 — fixed in 1.29.2, 2.1.1, 2.3.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.2, 2.1.1, 2.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-45292 or the next vulnerability affects your stack