What’s Vulnerable › Vulnerabilities
CVE-2024-45299: alf.io's preloaded data as json is not escaped correctly
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-06 · updated 2026-06-17
- Weakness: CWE-116
Description
alf.io is an open source ticket reservation system for conferences, trade shows, workshops, and meetups. Prior to version 2.0-M5, the preloaded data as json is not escaped correctly, the administrator / event admin could break their own install by inserting non correctly escaped text. The Content-Security-Policy directive blocks any potential script execution. The administrator or event administrator can override the texts for customization purpose. The texts are not properly escaped. Version 2.0-M5 fixes this issue.
Affected products
- alfio-event alf.io: before 2.0-m5 — fixed in 2.0-m5
How to fix
Upgrade to a fixed version: alfio-event alf.io 2.0-m5. Check the vendor advisory for mitigations.
References
- https://github.com/alfio-event/alf.io/commit/e7131c588f4ac31067a41d0e31e6a6a721b2ff4b
- https://github.com/alfio-event/alf.io/security/advisories/GHSA-mcx6-25f8-8rqw
Get alerted when CVE-2024-45299 or the next vulnerability affects your stack