What’s Vulnerable › Vulnerabilities
CVE-2024-45303: Discourse Calendar plugin event names susceptible to XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse Calendar plugin adds the ability to create a dynamic calendar in the first post of a topic to Discourse. Rendering event names can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. The issue is patched in version 0.5 of the Discourse Calendar plugin.
Affected products
- discourse-calendar: before 0.5 — fixed in 0.5
How to fix
Upgrade to a fixed version: discourse-calendar 0.5. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse-calendar/commit/81e1c8e3c4c02276fb890da7e3f684259aeb685c
- https://github.com/discourse/discourse-calendar/security/advisories/GHSA-rq37-8pf3-4xc8
Get alerted when CVE-2024-45303 or the next vulnerability affects your stack