What’s Vulnerable › Vulnerabilities
CVE-2024-45307: SudoBot missing authorization check in `-config` command
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-03 · updated 2026-06-17
- Weakness: CWE-285
Description
SudoBot, a Discord moderation bot, is vulnerable to privilege escalation and exploit of the `-config` command in versions prior to 9.26.7. Anyone is theoretically able to update any configuration of the bot and potentially gain control over the bot's settings. Every version of v9 before v9.26.7 is affected. Other versions (e.g. v8) are not affected. Users should upgrade to version 9.26.7 to receive a patch. A workaround would be to create a command permission overwrite in the Database. A SQL statement provided in the GitHub Security Advisor can be executed to create a overwrite that disallows users without `ManageGuild` permission to run the `-config` command. Run the SQL statement for every server the bot is in, and replace `<guild_id>` with the appropriate Guild ID each time.
Affected products
- onesoft-sudo sudobot: from 9.0.0 before 9.26.7 — fixed in 9.26.7
How to fix
Upgrade to a fixed version: onesoft-sudo sudobot 9.26.7. Check the vendor advisory for mitigations.
References
- https://github.com/onesoft-sudo/sudobot/commit/ef46ca98562f3c1abef4ff7dd94d8f7b8155ee50
- https://github.com/onesoft-sudo/sudobot/security/advisories/GHSA-crgg-w3rr-r9h4
Get alerted when CVE-2024-45307 or the next vulnerability affects your stack